Adding New Process Setup Options

This section illustrates adding new process setup options to a process. The examples in this section use the custom process AbrasiveJet Cut (see Adding a New Process to a Process Group). The first two examples mimic setup options for the process Watercut Jet. The last example illustrates further customization. The section contains the following subsections:

For more information on process setup options, see Working with Process Setup Options in Working with Cost Model Data and Metadata.

Adding a Setup Option: using CSL, Formula, and User Modes

This section contains an example of adding a setup option to a process. Following Waterjet Cut, this new process will include a setup option, bundleCount, for the number of blanks that are stacked and processed simultaneously.

Follow these steps to create the setup option:

  1. In the navigation pane, double-click AbrasiveJet Cut; in the editing pane, click the Process Setup Optoins tab.

    In this example, the process is new, and so is editable without an explicit override. For inherited objects, you must select Override Object from the Edit menu, or click the override icon, green_dude.png, in the toolbar.

  1. Scroll to the bottom of the editing pane, and click green_plus.png. Text boxes and a table for a new setup option appear.

    new_blank_pso.png

    Each line of the table will define an end-user input mode. You will define three modes:

    1. Default mode: uses the default bundle count 1. This value is specified by a simple CSL expression, consisting of just a numerical literal. (See Adding a Setup Option: Padding Cycle Time for another example of using CSL mode in a process setup option.)

    2. Computed mode: uses a computed bundle count. This value is specified by the CSL formula (defined in the process taxonomy module or a supporting library module) bundleAbrasiveJetCountComputed. (See bundleWaterjetCountComputed in the library module libWaterjetUtilities.csl.)

    3. User override mode: This value is entered by the end user.

  2. Add a line to the table, specifying the following column values:

    1. Mode Name: aDefaultValue

    2. Type: CSL

    3. Display Text:  Default Value

    4. Expression: 1

  3. Add a second line to the table, specifying the following column values:

    1. Mode Name: aaComputedValue

    2. Type: Formula

    3. Display Text: Computed Value

    4. Expression: bundleAbrasiveJetCountComputed

  4. Add a third line to the table, specifying the following column values:

    1. Mode Name: aaaUserOverride

    2. Type: User

    3. Display Text: User Override

    4. Min Value: 1

    5. Max Value: bundleAbrasiveJetCountComputed

  5. Enter the following information into the text boxes:

    1. Name: bundleCount

    2. Display Text: Number of Parts in Stack

    3. Description: Parts can be stacked to cut multiples at once. Maximum number of parts is determined by part thickness and the maximum effective stack thickness without sacrificing part quality.

    4. Default Mode Name: aDefaultValue

    5. Decimal Places: 1

      pso_bundle_count.png

  6. Select Save from the File menu, or click save_icon.png in the toolbar, to save your changes.
  7. To incorporate your changes into the cost model, select Publish Cost Model and Digital Factory from the File menu, or click publish_icon.png in the toolbar.

For more information on CSL, see CSL Language Overview in the chapter Working with Cost Model Logic.